Short answer: PHP 7.2 or higher
The longer answer:
1) For Toolbar Extras
The minimum requirement is PHP 5.6 which will be the same as WordPress minimum requirement by the time WordPress 5.2 will release in spring of 2019.
But really, you should not use PHP 5.6 nowadays anymore. It is already officially out of support since the end of 2018. This means no security patches will be available anymore by the PHP Group for webserver hosting providers.
Please, do yourself a favor and update to the PHP 7.2 or higher. This version is still under support, plus, it is also faster, more secure and brings many improvements with it. There’s even PHP 7.3, the latest release from December of 2018 which is already supported in WordPress 5.0 or higher. So you can also use that one. And you should if possible, as it is even faster than 7.2, yeah!
Do yourself a favor and do not use PHP 5.6 anymore, please. Even if that is the absolute minimum requirement of WordPress, and plugins like Elementor and others. This is a technical requirement. Security-wise or performance-wise it is not helpful to run an old, unsupported version. If your hosting provider is not able or willing to update his stuff then please change hosting companies.
It is your website, your business. Let’s run it on secure and fast servers. WordPress.org support page has great info on how to upgrade your PHP version.
2) For Add-Ons
For all official and supported Add-Ons that are from me (David Decker – DECKERWEB) the same applies as for the main/ base plugin explained above.
For all third-party Add-Ons (supported and recommended ones) this could be different. Here you have to look what the requirements are for the actual plugin you are about to use.
- Tagged Under: